python中import libvirt异常解决办法

  • 安装多版本python后,会因为libvirt从yum安装产生在其他版本python中import libvirt异常的问题
ImportError: /usr/lib64/libvirt.so.0: version `LIBVIRT_1.1.3' not found (required by /usr/local/lib/python2.7/site-packages/libvirtmod.so)
  • 这个问题意思是libvirt.so.0需要一个libvirtmod.so库文件,而且他是在python的site-packages目录下搜索的,但如果libvirt是用yum安装的话,应该就是安装到python2.6的目录下去了,所以复制一个过来即可
sudo cp /usr/lib64/python2.6/site-packages/libvirtmod.so /usr/local/lib/python2.7/site-packages

发表评论