centos7安装高版本ibus

  1. github上下载ibus
    > https://github.com/ibus/ibus/releases/tag/1.5.14
  2. 解压后安装
    $ ./autogen.sh --prefix='/usr' --sysconfdir='/etc' --libdir='/usr/lib' --enable-gtk-doc
    $ make
    $ sudo make install
  3. 出现错误分析
    • no such file emoji.json

      解决办法npm install emojione -g

    • 没有gsettings-schemas-convert

      解决办法 手动安装gconf

    • make时报错,说明缺少一些包的依赖

      解决办法 按照官网所说补齐依赖

      https://github.com/ibus/ibus/wiki/Install

发表评论