cmakelists对于c项目和c++项目的写法

  1. c项目
cmake_minimum_required(VERSION 3.6) 最小需要的cmake版本

project(libvirtTest)    项目名

set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -lvirt")    添加编译选项参数,不需要加的话省略这行

set(SOURCE_FILES libvirtTest.c) 将需要编译的源文件添加到这里
add_executable(libvirtTest ${SOURCE_FILES}) 生成的执行文件
  1. c++项目
cmake_minimum_required(VERSION 3.6)
project(libvirtTest)

set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")

set(SOURCE_FILES libvirtTest.cpp)
add_executable(libvirtTest ${SOURCE_FILES})
  1. cc1plus: 错误:无法识别的命令行选项“-std=c++11”
    • 此错误原因为老版本只支持-std=c++0x的写法,新版本用-std=c++0x的写法

发表评论